We have temporarily moved traffic off of the private wave carrier in question shortly after our last update. Things have been stable since, and we believe this issue to be resolved.
We will continue to work with that carrier to assure everything is clear before we bring them back on.
Posted May 09, 2024 - 17:13 UTC
Identified
Edit to the initial update:
Our initial thoughts seem to be incorrect, and have made a preliminary causation of it being related to the unplanned maintenance from our private wave carrier yesterday still having instability. We’re working with them, and figuring out other solutions to move traffic around this. Please bare with us.
Posted May 09, 2024 - 14:32 UTC
Investigating
Hello,
We are currently investigating issues with player drops in the London/EU region. We have identified that this is a different issue from yesterday, and will update here with more information soon.