New Status Alert
Incident Report for Gameserverkings
Resolved
As of around 2 hours ago services have been restored. We've been monitoring since then and we do not expect further issues. We remarking this as resolved.
Posted Dec 19, 2023 - 05:57 UTC
Monitoring
Fixes have been implemented and services are stable for around 45 minutes now. We will continue updating as we monitor the situation.
Posted Dec 19, 2023 - 02:54 UTC
Update
We are approaching the final stages of our maintenance. We expect to be fully operational and stable soon.

Thanks for your patience, and we again apologize for the inconvenience.
Posted Dec 19, 2023 - 01:06 UTC
Update
At this current time, I would not inform your clients, players, etc.. that services are stable or online. We are still performing critical maintenance and do not want to confirm services are stable at this current time. As always, we will update here when services are confirmed to be fully restored and stable.
Posted Dec 18, 2023 - 21:58 UTC
Update
Services are in the process of being restored. Most clients should now be online, but some are still down and we are working on them. We apologize for the continued downtime.
Posted Dec 18, 2023 - 21:10 UTC
Identified
We're still working diligently to bring your services online. We are performing emergency maintenance to the affected networking gear, and working with all hands on deck to quickly and efficiently restore your services. We appreciate your patience, and thank you for your understanding.
Posted Dec 18, 2023 - 20:03 UTC
Investigating
We're aware some of you are experiencing an outage in Dallas. This is related to the earlier maintenance which was posted at https://status.gameserverkings.com/. Unfortunately, that task ended and will not allow us to open it back up, but maintenance is still ongoing. The team is on it, and we should have an update and get the affected clients back online shortly. Thanks for the patience.
Posted Dec 18, 2023 - 18:43 UTC
This incident affected: Network - North America (Dallas, Texas - United States).