Elevated Latency on US-Europe traffic
Incident Report for Gameserverkings
Resolved
Our carriers seem to have routed around the problem with minimal latency. We're marking this incident as closed.
Posted Dec 07, 2023 - 07:03 UTC
Investigating
Hi everyone,

We're currently experiencing elevated latencies on traffic going between Europe and the U.S.
Our NOC is actively engaging with our carriers to figure out what's going on, as well as an ETA on a remedy.
Posted Dec 07, 2023 - 03:34 UTC
This incident affected: Network - North America (Dallas, Texas - United States, Ashburn, Virginia - United States, Los Angeles, California - United States) and Network - Europe (London - United Kingdom, Amsterdam - Europe).