Mass Disconnections in EU and US
Incident Report for Gameserverkings
Resolved
This incident is confirmed to be resolved. A post-mortem will follow shortly. We appreciate your patience during this time.
Posted Mar 13, 2024 - 00:04 UTC
Investigating
We are currently investigating this incident. We are aware of some disconnects affecting a large number of users in the last 30 minutes.

We will update ASAP.
Posted Mar 12, 2024 - 05:03 UTC
This incident affected: Network - North America (Dallas, Texas - United States, Ashburn, Virginia - United States) and Network - Europe (London - United Kingdom).