DFW Incident

Incident Report for Gameserverkings

Resolved

As of 3 hours ago all services were restored.

The faulty device has been replaced and services are all healthy again. We're not expecting any further impact.
Posted May 06, 2024 - 21:36 UTC

Investigating

Hi guys,

We're aware of an incident impacting certain clients in our DFW region. We're working on a resolution.
Posted May 06, 2024 - 12:01 UTC