Mass Disconnections in EU and US
Incident Report for Gameserverkings
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 21:26 UTC
Monitoring
We have pushed fixes to all locations and are monitoring proactively to ensure all services fully stabilize and remain stable.
Posted Mar 13, 2024 - 11:12 UTC
Update
We have several engineers working on pushing out a full fix ASAP.

Updates will follow as we have them for you.
Posted Mar 13, 2024 - 08:26 UTC
Identified
The issue has been narrowed down, and we are diligently working on a permanent and full fix. We hope to have a more positive update to share soon.
Posted Mar 13, 2024 - 05:03 UTC
Investigating
We're currently investigating a similar disconnection event as last night. We're already working on a fix, and will update everyone soon. Thanks!
Posted Mar 13, 2024 - 02:44 UTC
This incident affected: Network - North America (Dallas, Texas - United States) and Network - Europe (London - United Kingdom).