New Status Alert
Incident Report for Gameserverkings
Resolved
This incident has been resolved.
Posted Mar 19, 2023 - 07:24 UTC
Investigating
We are once again aware of the increased ping and packet loss for customers in the EU region, and are once again working on fixing it. This does not affect all clients, but for those affected we do understand the severity of the issue.

We will continue to update as the situation progresses.
Posted Mar 18, 2023 - 15:54 UTC