Connectivity issues in London
Incident Report for Gameserverkings
Resolved
Back to normal. Our apologies for the inconvenience.
Posted Sep 12, 2023 - 09:28 UTC
Monitoring
Hi everyone,

We just had brief connectivity issues in London, a fix has been implemented and we are monitoring now.
Posted Sep 12, 2023 - 09:22 UTC
This incident affected: Network - Europe (London - United Kingdom).