New Status Alert
Incident Report for Gameserverkings
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 02:12 UTC
Investigating
Multiple Tier1 ISPs are reported to have mild degradation of service. This is believed to be caused by at least 1, but maybe more subsea cable outages.

We’re doing our best to route around these issues, but the disruption seems widespread. Expect more wider loss and slightly instability until this outage is resolved.
Posted Apr 06, 2024 - 17:15 UTC