GTT Issues in London

Incident Report for Gameserverkings

Resolved

Things appear to be stable. We’re closing out this incident but will continue to monitor.
Posted May 04, 2024 - 20:42 UTC

Investigating

Hi everyone,

GTT is experiencing issues in London which is causing connecting drops and general instability.

We're routing around as much as we can.
Posted May 04, 2024 - 17:19 UTC