London incident
Incident Report for Gameserverkings
Resolved
This incident has been resolved.
Posted Sep 12, 2023 - 17:24 UTC
Update
Services are stabilizing, no further impact expected.
Posted Sep 12, 2023 - 11:22 UTC
Investigating
Hi everyone,

We’re aware of repeated impact in London, we’re rolling out a permanent fix as we speak.

We’ll update you shortly.
Posted Sep 12, 2023 - 11:21 UTC
This incident affected: Network - Europe (London - United Kingdom).