New Status Alert
Incident Report for Gameserverkings
Resolved
This incident has been resolved.
Posted May 13, 2023 - 03:48 UTC
Investigating
GTT is currently performing emergency maintenance in both Amsterdam and London, and just recently caused a drop of pop.

We are monitoring the situation, and have asked for more updates from them. We will update ASAP.

For now, we are diverting traffic to prevent any further issues.
Posted May 12, 2023 - 22:59 UTC