New Status Alert

Incident Report for Gameserverkings

Resolved

This incident has been resolved.
Posted Mar 18, 2023 - 04:07 UTC

Investigating

We are aware of the elevation in packet loss and are already working on a fix. Thanks for your patience.
Posted Mar 17, 2023 - 22:09 UTC